1.6 hdi lumpy cold start - EGR?

Posts related to switching of the EGR.

Return to EGR Off

1.6 hdi lumpy cold start - EGR?

Postby Zion » Tue Jul 03, 2018 11:39 pm

Hi lads, sorry if this is in the wrong section. I have a 2007 Citroen Berlingo 1.6 HDi 75, it runs perfect when hot, no codes in Lexia, but cold start while instant, is terrible. It fires up instantly but hunts and misfires and smokes unburnt fuel until the coolant temp hits 60+ then runs like clockwork.

I notice in Lexia data logger run, that EGR swings wildly around at this point between 15% and 90% all over the place, and air flow hunts up and down around 240 to 280 as does fuel pressure. I pulled the MAF plug and instant smooth running, EGR shuts to zero and air flow reference jumps to steady 400 mg/cp. I've been told this points to the EGR being the issue, so I've got a blanking plate to fit tomorrow. Question is, will I need to remove EGR from the map, and does this all sound right to you guys or do you think it's something else?

Van is on 60k miles, fresh service, new glow plugs and relay, proven to be working and torqued to 10nm. Injector fuel correction is under 0.2 on all 4 injectors btw.

Zion
New user
 
Posts: 4
Joined: Tue Jul 03, 2018 10:28 pm
Location: United Kingdom

Re: 1.6 hdi lumpy cold start - EGR?

Postby Zion » Wed Jul 04, 2018 6:48 am

Also should explain why I posted on this forum, I need to know what the ECU is looking at to decide EGR value during cold start. Why the problem suddenly disappears at coolant temp of 60 or above, I suspect it's intake air temp and coolant temp but thought someone on here would know for sure due to mapping these etc....make sense now?

Cheers in advance for any info lads.

Zion
New user
 
Posts: 4
Joined: Tue Jul 03, 2018 10:28 pm
Location: United Kingdom

Re: 1.6 hdi lumpy cold start - EGR?

Postby tizz » Wed Jul 04, 2018 10:51 am

Disconnect egr plug, and test.
No limp mode, just check engine appears.

tizz
Bronze
 
Posts: 34
Joined: Mon Oct 07, 2013 9:36 pm
Location: UK

Re: 1.6 hdi lumpy cold start - EGR?

Postby Zion » Wed Jul 04, 2018 2:01 pm

Thanks mate, I wondered about that, didn't want to trigger limp mode on my commute to work, very busy roads.

Zion
New user
 
Posts: 4
Joined: Tue Jul 03, 2018 10:28 pm
Location: United Kingdom


Return to EGR Off

Who is online

Users browsing this forum: No registered users and 1 guest